EPICSsynApps: vme

Module Owner: Tim Mooney

This page is the home of the synApps vme module. This module contains device support, databases, and MEDM displays supporting some VME boards.

Please email any comments and bug reports to Tim Mooney, who is responsible for coordinating development and releases.

Support

  1. Record support:
    vmeRecord

  2. Device support:
    Acromag 9210
    Acromag 9440
    Bunch Clock Generator
    Generic A32 VME access
    Heidenhain IK320 VME counter/interpolator
    HP 10895A Laser Axis
    Joerger VSxx Scaler
    Machine Status Link (MSL)
    Varoc SSI encoder
    VMIC VMI4116 16-bit D/A converter

  3. Driver support:
    Avme9210
    Bunch Clock Generator
    IK320

Where to find it

You can download the software from the links in the table below:

Module Version

EPICS Release

Filename

Documentation

Release Notes

Known Problems

R2-8-1

3.14.12.3

vme_R2-8-1.tar.gz


release notes

None

R2-8

3.14.12.1

vme_R2-8.tar.gz


release notes

None

R2-7

3.14.11

vme_R2-7.tar.gz


release notes

None

R2-4-4

3.14.6
3.14.7

vme_R2-4-4.tar.gz


release notes

None

R2-4-2

3.14.6
3.14.7

vme_R2-4-2.tar.gz


release notes

None

R2-4-1

3.14.6
3.14.7

vme_R2-4-1.tar.gz


release notes

None

R2-4-0

3.14.6
3.14.7

vme_R2-4-0.tar.gz


release notes

None

R2-3

3.14.5

vme_R2-3.tar.gz


release notes

None

Required Modules

vme version

Requires module

Release tested

R2-8-1

seq
calc
sscan
std
asyn

R2-1-12
R3-2
R2-6-6
R3-0
R4-21

R2-7

seq
calc
sscan
std
asyn

R2-0-12
R2-8
R2-6-6
R2-8
R4-13

R2-4-4

seq
calc
sscan
std
asyn

R2-0-11
R2-5
R2-5-1
R2-5-1
R4-6

R2-4-2

seq
calc
sscan
std
asyn

R2-0-10
R2-5
R2-5-1
R2-5-1
R4-3

R2-4-1

seq
calc
sscan
std
asyn

R2-0-10
R2-3
R2-3
R2-3
R4-2

R2-4-0

seq
calc
sscan
std
asyn

R2-0-8
R2-3
R2-3
R2-3
R1-2

R2-3

std
calc
sscan

R2-3
R2-3
R2-3

Installation and Building

After obtaining a copy of the distribution, it must be installed and built for use at your site. These steps only need to be performed once for the site (unless versions of the module running under different releases of EPICS and/or the other required modules are needed).

  1. Unzip and untar the distribution, e.g. on Unix:

    gunzip vme_R2-4-4.tar.gz
    
    tar -xvf vme_R2-4-4.tar

    This is usually performed from the synApps 'support' directory and will produce the subdirectory

    vme/2-4-2
  2. Edit the config/RELEASE file of the application that will use vme to point to this directory.

  3. Edit config[ure]/RELEASE file and set the paths to your installation of EPICS base and to your versions of other modules on which vme depends.

  4. Run gnumake (make on Linux) in the top level directory and check for any compilation errors.

  5. Please email  David Kline  so that a record can be kept of which sites are using this software.

Documentation

The following documentation is available:

In Use

This software was originally developed by the APS BCDA group, other APS-affiliated developers, and many members of the EPICS Collaboration.